Also stuck at no route found for GET /hello (HelloWeb.Router)

I am a new with Phoenix and Elixir…
Just trying to follow the hello app in the book Programming Phoenix 1.4

I am at the point of editing router.ex to add the /hello route…

I edited the file and ftp to Ubuntu server directory /home/hello/lib/hello_web/router.ex

I am getting "no route found when I do a request from browser…

Do phoenx need to be restarted? And if so what is the graceful way to do that?
I did CTL-Z and when I restart I get errors with port 4000 in use.

any suggestions?

I have rebooted Linux and restarted phoenix and I still get the error…


If you ever need to restart Phoenix use C-c C-c. C-z will suspend the program, you can restore it with the fg command in the shell or list background processes for that shell with bg. Phoenix should recompile and reload any code changes you make without you needing to do that for most files (if you edit mix.exs then you’ll need to reload the entire server).

Regarding your error, you will get some error until you’ve implemented each of the controller, view, and template for that section.

Thanks for the tip on how to restart.

But the error is the wrong error.
I added "get /hello , HelloController , :world "

The error I am getting is “no route found”…the error should be HelloController not found…

So it seems to me, the phoenix is not recognizing the change in the router.ex file…


Where are your quotes in that line? It should be:

get "/hello", HelloController, :world

With quotes around the /hello.

ok. problem solved…I was building/starting app in /root/hello I should have been in /home/hello…

Now, on to the other examples in the book.