Application.start :error 'no such file or directory'

I am running two applications: GoFish.PhoenixApplication and GoFish.GameApplication In one of the controllers of the phoenix application, I want to start the Game like this: Application.start(GoFish.GameApplication)
but it doesn’t start it.
I then tried in IEX but got this error:

iex(9)> Application.start(GoFish.GameApplication)
{:error, {'no such file or directory', ''}}

Then I tried compiling the code again to make sure it was there:

warning: redefining module GoFish.GameApplication (current version defined in memory)


But the error is still the same:

iex(12)> Application.start(GoFish.GameApplication)
{:error, {'no such file or directory', ''}}

I suspect it has something to do with the Elixir Prefix in but I’m not sure.

The runtime uses the word “application” to mean a very specific thing - the file with the .app extension will be generated by the Elixir compiler if things are configured correctly.

Starting applications is also usually handled automatically by mix etc; calling Application.start in a controller seems strange.

Can you post some code from, say, GoFish.GameApplication?