(ArgumentError) argument error :erlang.integer_to_binary("115762146899049015649")

I was actually converting the google_id to string but when i run my programm i am getting the error…

google_id = Integer.to_string(user["id"])

when i run the programm mix run --no-halt and try to login with google. I am getting this error:

** (exit) an exception was raised:
    ** (ArgumentError) argument error
        (goop 0.1.0) lib/rath/mutations/users.ex:28: Rath.Mutations.Users.google_find_or_create/3
        (goop 0.1.0) lib/jetray/routes/google_auth.ex:62: anonymous fn/2 in Jetray.Routes.GoogleAuth.do_match/4
        (goop 0.1.0) lib/plug/router.ex:284: Jetray.Routes.GoogleAuth.dispatch/2
        (goop 0.1.0) lib/jetray/routes/google_auth.ex:1: Jetray.Routes.GoogleAuth.plug_builder_call/2     
        (plug 1.11.1) lib/plug.ex:168: Plug.forward/4
        (goop 0.1.0) lib/plug/router.ex:284: Jetray.dispatch/2
        (goop 0.1.0) lib/jetray.ex:1: Jetray.plug_builder_call/2

Your user["id"] is already a string, not an integer.


Yeah that was the case.