Cannot install Elixir following the guide


I tried to install Elixir by following the guide on the official website. It says I have the latest version of Erlang and Elixir. but it does not work at all. Does anyone know how to fix this?

This is a windows one? Take a look at that issue

no, it seems to be a virtual ubuntu inside windows…

anyway the error seems to be the same or very similar so installing older erlang might help, something like that

Nope, it really looks like this new Windows-Subsystem-For-Linux stuff. MS and Canonical both insist on it not beeing virtualized or emulated but “kernel supported”.

Aside of that, without some more information from the OP we can only guess.

1 Like

It is Ubuntu on Windows from the latest WIndows 10 patch.
I followed the guide but it didn’t work. I tried the installer for Windows, which is completed. Now I do not see anything new in Command Promt or Bash :frowning:

I may try to install virtual machine and see how it goes.

I feel noob when I see your answer :slight_smile:

Nice to see windows trying to support linux kernel.

Thanks for enlightenment.

On windows is suggest to use choco installation. You’ll run into problems though as soon as you start using NIFs. Therefore I’d suggest a Linux in a virtual box or a dual boot.

I dislike installing on Windows because it is within the Command Promt, not in the Bash terminal which is built-in of various code editor.

I have finally got it to work. First, we must update our Windows build to the latest by joining the Insider program. Then Ubuntu 16 will be allowed to install. Reinstalling Ubuntu on Windows will bring to version 16. Afterwards, we just install Erlang And Elixir like instructed :slight_smile: