Cant install / compile comeonin on Core2Duo

I tried to install this dependency called “comeonin” on MacOS Sierra and also on Linux but failed to compile. Both computers have a Core2Duo processor.
I’m using latest Elixir and Erlang

could not compile dependency :comeonin, “mix compile” failed. "

I followed these instructions and tried to add the following lines to Makefile but I dont know if I did it correctly:

added: -arch i386 -arch x86_64 to both CFLAGS and LDFLAGS in Makefile

First I added both of those options on the first line on CFLAGS
I dont really know C programming, so I created a LDFLAGS with those options, then I edited the LDFLAGS inside the if statement and did some more combinatinos but still doesnt compile.

Please help!

1 Like

tryxcode-select --install in to ensure you have the dev commandline tools installed…

I would not change the makefile, it should work if you have gcc etc installed…

this might also help:

For most plugins, it is good if you have installed the following packages OR their equivalent on your OS
macOS: Install these via homebrew coreutils automake autoconf openssl libyaml readline libxslt libtool unixodbc
Ubuntu: automake autoconf libreadline-dev libncurses-dev libssl-dev libyaml-dev libxslt-dev libffi-dev libtool unixodbc-dev
Fedora: automake autoconf readline-devel ncurses-devel openssl-devel libyaml-devel libxslt-devel libffi-devel libtool unixODBC-devel

taken from

1 Like

thank you for answering!
When I tried to install comeonin, the latest (6/12/2017) xcode developer tools was installed as I had downloaded the latest version from Apple (without xcode app) and also coreutils were installed. I also installed now the brew version but it still does not compile.

I installed asdf and I’m not sure if I’m supposed to use it to download a precompiled binary of the lib I need, as I did not find any precompiled comeonin binary.

1 Like

sorry asdf not needed for this, just where I got that instructions for packages from…

make sure you have atleast coreutils automake autoconf installed with brew…

can you run make --debug=v inside the deps/comeonin folder?

it’s one of those where it just works for the rest of us(as the packages are already installed)… but I’m not certain which packages is required…

1 Like

Thank you. Your advice helped me to find out that I needed to install/compile sub-dependencies. And it was possible to get comeonin to work on Linux.

On OSX I stil get the error:
/bin/sh: 0.59.0: No such file or directory
make: *** [Makefile:27: priv/] Error 1

The command “make --debug=v” now displays:

** (Mix) Can’t continue due to errors on dependencies

I tried the advice from here but it didnt work. I tried to export shell, to create symbolic links, etc.
Cant I just hardcode that shell into makefile ?

1 Like

If you are still having issues, please open an issue.

1 Like