Constraint error when attempting to delete struct

Hello everyone,
I have the following models and changesets for users and addresses:

schema "users" do
        field :title, :string
        field :f_name, :string
        field :l_name, :string
        field :DOB, :date
        field :email, :string
        field :username, :string
        field :password, :string, virtual: true
        field :password_confirmation, :string, virtual: true
        field :password_hash, :string
        field :image, Assistant.Image.Type

        has_one :addresses, Assistant.Web.Address
        has_many :appointment, Assistant.Web.Appointment
        belongs_to :role, Assistant.Web.Role


    #checks the changeset of the controller to see whether the input matches the rules I set here
    def changeset(model, params \\ :invalid) do
        |> cast(params, ~w(title f_name l_name DOB email username role_id))
        |> cast_attachments(params, [:image])
        |> validate_required([:title, :f_name, :l_name, :DOB, :email, :username, :role_id, :image])
        |> validate_length(:username, min: 2, max: 20)
        |> unique_constraint(:username)
        |> assoc_constraint(:role)
        |> cast_assoc(:addresses, required: true)


schema "addresses" do
        field :house_n, :integer
        field :address_1, :string
        field :address_2, :string
        field :post_code, :string
        field :city, :string
        field :county, :string
        field :country, :string

        belongs_to :user, Assistant.Web.User, foreign_key: :user_id


      @doc """
      Builds a changeset based on the `struct` and `params`.
    def changeset(struct, params \\ %{}) do
        |> cast(params, [:house_n, :address_1, :address_2, :post_code, :city, :county, :country])
        |> validate_required([:house_n, :address_1, :address_2, :post_code, :city, :county, :country])

When I try to delete a new user I have created it gives me this error:
constraint error when attempting to delete struct:

  • foreign_key: addresses_user_id_fkey

I have searched through the forum and on stack overflow and the solution seems to be to add the foreign_key_constraint(), but I am not exactly clear on how to go on about it as I have tried following the suggestions, but so far I keep getting the same error. Has it got anything to do with the cast_assoc()? I’ve got that from the book programming phoenix but online I found varying opinions on it so I thought maybe that could be the issue.

Thank you for your help :slight_smile:

Maybe You could set the on_delete option between user and its addresses association.

By default, it will do nothing… Thus I think it is why You get this error.

For this to work, You could look at


This would be in your addresses migration

add :user_id, references("users"), on_delete: :delete_all

and in the schema

has_one :addresses, Assistant.Web.Address, on_delete: :delete_all

It is not tested, but it might help…


Thanks for your reply :slight_smile:
I would also delete the cast_assoc from the changeset right?

It works!! it was the on_delete thing thank you :slight_smile:

Glad it works :slight_smile: