Could not compile dependency :comeonin, "mix compile" failed. You can recompile this dependency with "mix deps.compile comeonin"

D:\Projects\blog>iex -S mix phoenix.server
Eshell V8.0 (abort with ^G)
==> comeonin
could not compile dependency :comeonin, “mix compile” failed. You can recompile this dependency with “mix deps.compile comeonin”, update it with “mix deps.update comeonin” or clean it with “mix deps.clean comeonin”
==> blog
** (Mix) Could not find the program nmake.

You will need to install the C compiler nmake to be able to build
Comeonin.

One option is to install a recent version of
Visual C++ Build Tools
either manually or using Chocolatey -
choco install VisualCppBuildTools.

After installing Visual C++ Build Tools, look in the Program Files (x86)
folder and search for Microsoft Visual Studio. Note down the full path
of the folder with the highest version number.

Open the run command and type in the following command (make sure that
the path and version number are correct):

cmd /K "C:Program Files (x86)Microsoft Visual Studio 14.0VCcvarsall.bat" amd64

This should open up a command prompt with the necessary environment variables set,
and from which you will be able to run the commands mix compile, mix deps.compile
and mix test.

See https://github.com/riverrun/comeonin/wiki/Requirements for more
information.

UPDATED:

I have follow this document guideline: https://medium.com/@diamondgfx/introduction-fe138ac6079d#.lrjhchhmw

and I failed this step:

Same here, note the addition of {:comeonin, “~> 2.3”}. Now, let’s shut down the server we’ve been running and run mix deps.get. If all goes well (it should!), then now you should be able to rerun iex -S mix phoenix.server to restart your server.

Since you did not provide any markers for begin and end of the copied text, as well as you did not provide an actual question, I do assume the following:

  • The complete post is what you got on the shell
  • The actual question is “what can I do to fix this?”

To actually beeing able to help, we need to know, if you already read and tried the solution provided in the copied snippet and perhaps provide an actual question/explanation.

1 Like

Thank NobbZ, I have update my question,

The post you linked to seems to assume linux, so you might to do some specialcasing for windows on your own.

Especially in this case, the solution to your problem seems to be included in the original post you wrote and I assumed beeing a 100% copy of some terminal output, so I will ask you again, did you actually follow the instructions that have been given to you on the terminal?

1 Like

I have try all one by one , but the problem still occurred.

The following suggestion command I have tried,

You can recompile this dependency with “mix deps.compile comeonin”, update it with “mix deps.update comeonin” or clean it with “mix deps.clean comeonin”

1 Like

Did you also install the MS Build Tool stuff and opened up a new terminal with correct environment settings as suggested in your original post?

2 Likes

I installed with
choco install VisualCppBuildTools successfully, then I looked into this folder
C:\Program Files (x86)\Microsoft Visual Studio 14.0 I did not see VCcvarsall.bat file.

I still trying to find the solution this problem …

1 Like

Then go on and try to find a more current/older version in that MSVS folder, as it is said in the message, For me it is: C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\vcvarsall.bat

2 Likes

Have you been able solve your problem?

1 Like

NobbZ , thank for you help, I have find the entire drive C but not found that file.

So maybe it is on another drive? If it does not exist on your computer, you probably did something wrong during install? Did you run the choco install command in an elevated shell?

Also, please make sure that windows did actually search under Program Files (x86), this is one of the folders windows skips per default when searching.