Dependency Error: circuits_uart

I am running on windows 10, in my mix.ex file i have added the following dependency [:circuits_uart, “~> 1.4”]. When i ran mix phx.server to start my server i received the following error:

(Mix) Could not compile with “C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.23.28105\bin\Hostx64\arm\nmake.exe” (exit status: 2).
You may need to install mingw-w64 and make sure that it is in your PATH. Test this by
running gcc --version on the command line.

If you do not have mingw-w64, one method to install it is by using
Chocolatey. See to install Chocolatey and run the
following from and command prompt with administrative privileges:

choco install mingw

I did install Chocolatey and proceeded installing mingw, but unfortunately i am still getting the same error. Please help, how can i fix the error?

NOTE: I am a newbie to Elixir.

Sadly there is not much in the docs, except that it should work under windows with cygwin.

My assumption is, that you need to compile the project from within a cygwin terminal.

getting the same error when I compile from cygwin terminal.