Deps installation issue

I want to add uberauth package but when i run mix deps.get it gives me this error.

It looks like you’ll need to update phoenix from 1.2.5. That version is over 2 years old, so it seems that Ueberauth is using features that are newer than what Phoenix is pinned to.

You could try to override the dependency, but that may lead to errors / unexpected behavior, so I would recommend extreme caution.


Thank you for the kind reply,

fixed it by using compatible versions of uberauth which works with phoenix 1.2

uberauth = 0.3
uberauth_github = 0.4