Difficulties working with pre-compiled library

I’m attempting to use a pre-compiled library in my project, but running into problems. Running mix deps.get and mix deps.compile seem to work fine, but when I actually try to start the application it fails with this output:

** (Mix) Could not compile dependency :roslib, "/Users/dhowland/.mix/rebar3 bare compile --paths /Users/dhowland/code/my_project_umbrella/_build/dev/lib/*/ebin" command failed. You can recompile this dependency with "mix deps.compile roslib", update it with "mix deps.update roslib" or clean it with "mix deps.clean roslib"

Running the rebar command directly gives me this:

===> Compilation failed: there is no code in this directory (/Users/dhowland/code/my_project_umbrella), it is unreadable or for some other reason is not a recognizable application structure.

I tried creating a new test project and importing the library and everything seems to work fine.

Any suggestions for things to check or try?

Try creating Makefile with content:


.PHONY: all

And I think it should work.

Thanks for the suggestion. I added a Makefile as you suggested at the root of my app, added elixir-make to my deps list (was not using it previously) and recompiled. Same result as before when I start the app though.