Elixir 1.9 - issues on Windows 10

Hi,

I’m having trouble running Elixir 1.9 on Windows 10. I’ve looked at the issue tracker and couldn’t find anything that seemed applicable. I was going to post my own but thought I’d check here first.

The problem is that I can’t run elixir basically at all. Every command (elixir, iex, mix) opens an Erlang window (console? Not sure what it’s called). For iex, the window does start a session. But for every other command the window is empty. This means I can’t start any of my applications, run mix commands or even check version of elixir.

I don’t have any logs or anything because I don’t know where to get them (if there are any).
I did, accidentally, do some narrowing down, so I’m pretty sure this is specifically and elixir 1.9 issue.

steps:
I upgraded elixir from 1.8 and erlang from 21 to 22 when the problem started. Installed via chocolatey.
Then I uninstalled everything and used the web installer from elixir-lang.org instead.
Uninstalled that and used chocolatey again but installed erlang and elixir separately, since you can’t choose erlang version in the web installer. Installed erlang 21, since I thought it was an erlang issue at this point.
Then I downgraded to elixir 1.8.2 and finally everything worked again. So just to be sure I upgraded erlang to 22 again and it still worked.

Hey,

I was wondering if the elixir 1.9 is added to path when you install it?

Also even if it is an old article https://medium.com/@rpw952/elixir-development-on-windows-10-ff7ca03769d#.phb652r7e this may provide some help.

Especially this part

@powershell -NoProfile -ExecutionPolicy Bypass -Command "iex ((New-Object System.Net.WebClient).DownloadString('https://chocolatey.org/install.ps1'))" && SET "PATH=%PATH%;%ALLUSERSPROFILE%\chocolatey\bin"
1 Like

Yes, elixir is added to the path correctly. I mean, something is happening, just the wrong thing :slight_smile:
I’ve been using elixir on windows for quite some time before this, so it’s something specific to version 1.9.

I hadn’t seen that powershell trick though. I’ve just been starting iex as iex.bat. So thanks for that!

Glad i could offer some assistance