Error loading module 'Elixir.Mix.Dep.Converger': corrupt file header

I installed the latest versions of the Erlang and Elixir:

asdf current
elixir          1.12.2-otp-24   /Users/romenigld/.tool-versions
erlang          24.0.5          /Users/romenigld/.tool-versions
nodejs          15.8.0          /Users/romenigld/.tool-versions
postgres        9.6.21          Not installed. Run "asdf install postgres 9.6.21"
ruby            3.0.0           /Users/romenigld/.tool-versions
yarn            1.22.10         /Users/romenigld/.tool-ver

I have now these versions in global mode.
After install these versions I successfully run the mix local.hex.
But when I try to run the command for install the Phoenix Framework 1.5.10 I get this errors:

 mix archive.install hex phx_new 1.5.10

14:18:40.486 [error] beam/beam_load.c(128): Error loading module 'Elixir.Mix.Dep.Converger':
  corrupt file header

14:18:40.486 [error] Loading of /Users/romenigld/.asdf/installs/elixir/1.12.2-otp-24/bin/../lib/mix/ebin/Elixir.Mix.Dep.Converger.beam failed: :badfile

** (UndefinedFunctionError) function Mix.Dep.Converger.converge/4 is undefined (module Mix.Dep.Converger is not available)
    (mix 1.12.2) Mix.Dep.Converger.converge([], %{}, [env: :prod], #Function<0.28620829/3 in Mix.Dep.Fetcher."-fun.do_fetch/3-">)
    (mix 1.12.2) lib/mix/dep/fetcher.ex:16: Mix.Dep.Fetcher.all/3
    (mix 1.12.2) lib/mix/tasks/deps.get.ex:31:
    (mix 1.12.2) lib/mix/task.ex:394: anonymous fn/3 in Mix.Task.run_task/3
    (mix 1.12.2) lib/mix/project.ex:353: Mix.Project.in_project/4
    (elixir 1.12.2) lib/file.ex:1560:!/2
    (mix 1.12.2) lib/mix/local/installer.ex:341: anonymous fn/4 in Mix.Local.Installer.fetch/3
    (mix 1.12.2) lib/mix/project_stack.ex:22: Mix.ProjectStack.on_clean_s

I tried as well on this way and it was not possible:

 mix archive.install
Are you sure you want to install ""? [Yn] y
** (Mix) fetching from URIs require a checksum to be given

Could not run archive.install for:

Please download the file above to your current directory and run:

    mix archive.install ./phoenix_new.ez

You can download it either with your browser or via the command line.

On Unix-like operating systems (Linux, macOS):



    curl -o phoenix_new.ez

On Windows / PowerShell (Windows 7 or later):

    powershell -Command "Invoke-WebRequest -OutFile phoenix_new.ez"


    powershell -Command "(New-Object Net.WebClient).DownloadFile('', 'phoenix_new.ez')"
❯ mix hex.config
api_key: nil (default)
api_url: "" (default)
cacerts_path: nil (default)
cache_home: "/Users/romenigld/.hex" (default)
config_home: "/Users/romenigld/.hex" (default)
data_home: "/Users/romenigld/.hex" (default)
diff_command: "git diff --no-index __PATH1__ __PATH2__" (default)
http_concurrency: 8 (default)
http_proxy: nil (default)
http_timeout: nil (default)
https_proxy: nil (default)
mirror_url: nil (default)
no_proxy: nil (default)
no_verify_repo_origin: false (default)
offline: false (default)
repos_key: nil (default)
resolve_verbose: false (default)
unsafe_https: false (default)
unsafe_registry: false (default)
❯ mix
Hex:    0.21.2
Elixir: 1.12.2
OTP:    24.0.5

Built with: Elixir 1.11.4 and OTP 21.3

I run the commands:

 ❯ mix archive.uninstall phx_new
Could not find a local artifact named "phx_new". We found:
* hex-0.21.2
Archives installed at: /Users/romenigld/.asdf/installs/elixir/1.12.2-otp-24/.mix/archives
❯ mix archive.install hex phx_new 1.5.10
Resolving Hex dependencies...
Dependency resolution completed:
  phx_new 1.5.10
* Getting phx_new (Hex package)
All dependencies are up to date
Compiling 10 files (.ex)
Generated phx_new app
Generated archive "phx_new-1.5.10.ez" with MIX_ENV=prod
Are you sure you want to install "phx_new-1.5.10.ez"? [Yn] y
* creating /Users/romenigld/.asdf/installs/elixir/1.12.2-otp-24/.mix/archives/phx_new-1.5.10

And now worked. I will test now!

mix -v
Phoenix v1.5.10