Error when trying to start a new liveview project

I keep getting this error when starting a new liveview project:

Unchecked dependencies for environment dev:
* phoenix_live_view (Hex package)
  the dependency does not match the requirement "~> 0.3.1", got "0.15.5"
** (Mix) Can't continue due to errors on dependencies

I don’t know where the 0.15.5 came from.

I’ using
phx: 1.5.8
elix: 1.11.0
erl: 23
nod: 14x

the project runs until I include the {"phoenix_live_view: “~> 0.3.1”} on the dependency list.

what is the way to fix this dependency conflict?


LiveView’s latest version is indeed 0.15.5. I am not sure why you are putting 0.3.1.

Try putting the version 0.15.5


thanks will try that, I’m following a video

that did it, thank you very much, this forum is great and very active…