Error while uploading multiple images using arc

Hi there,
I am using trying to upload multiple images using arc. It works for the first 2 images but then it throws this error. I am unable to figure out what is wrong. Can anyone ran into this issue before?.

[error] Ranch listener ImageerWeb.Endpoint.HTTP had connection process started with :cowboy_clear:start_link/4 at #PID<0.552.0> exit with reason: {:function_clause, [{:cowboy_http, :commands, [{:state, #PID<0.438.0>, ImageerWeb.Endpoint.HTTP, #Port<0.21>, :ranch_tcp, :undefined, %{env: %{dispatch: [{:, [], [{:, [], Phoenix.Endpoint.Cowboy2Handler, {ImageerWeb.Endpoint, []}}]}]}, stream_handlers: [:cowboy_telemetry_h, :cowboy_stream_h]}, “”, %{}, {{127, 0, 0, 1}, 35770}, {{127, 0, 0, 1}, 4000}, :undefined, #Reference<0.3617101559.755499013.50163>, true, 11, {:ps_request_line, 0}, 65535, 9, :done, 1000, [{:stream, 10, {:cowboy_telemetry_h, {:state, {:cowboy_stream_h, {:state, :undefined, ImageerWeb.Endpoint.HTTP, #PID<0.581.0>, :undefined, :undefined, :undefined, :undefined, 0, :nofin, “”, 0, …}}, #Function<0.122385210/1 in :cowboy_telemetry_h."-fun.metrics_callback/1-">, :undefined, %{body_length: 0, cert: :undefined, has_body: false, headers: %{“accept” => “text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,/;q=0.8,application/signed-exchange;v=b3;q=0.9”, “accept-encoding” => “gzip, deflate, br”, “accept-language” => “en-US,en;q=0.9”, “cache-control” => “max-age=0”, “connection” => “keep-alive”, “cookie” => “_imageer_key=SFMyNTY.g3QAAAACbQAAAAtfY3NyZl90b2tlbm0AAAAYLXkwSGtPc0FWYU5HYWd5dzRtYnNmSElWbQAAAA1waG9lbml4X2ZsYXNodAAAAAFtAAAABGluZm9tAAAAG0ltYWdlIGNyZWF0ZWQgc3VjY2Vzc2Z1bGx5Lg.WprgZRVN3tAJjywzi0yuIop8LaAuoyIulwnpw5o52MU”, “host” => “localhost:4000”, …}, host: “localhost”, method: “GET”, path: “/images”, peer: {{127, 0, …}, 35770}, pid: #PID<0.552.0>, port: 4000, qs: “”, …}, :undefined, :undefined, ImageerWeb.Endpoint.HTTP, -576460733877363932, :undefined, :undefined, :undefined, :undefined, :undefined, %{#PID<0.581.0> => %{…}}, [], …}}, “GET”, :“HTTP/1.1”, :undefined, :undefined, 0, []}, {:stream, 9, {:cowboy_telemetry_h, {:state, {:cowboy_stream_h, {:state, :undefined, ImageerWeb.Endpoint.HTTP, #PID<0.573.0>, :undefined, #PID<0.573.0>, :undefined, :undefined, 1000000, :nofin, “”, …}}, #Function<0.122385210/1 in :cowboy_telemetry_h."-fun.metrics_callback/1-">, :undefined, %{body_length: 256338, cert: :undefined, has_body: true, headers: %{“accept” => “text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,/;q=0.8,application/signed-exchange;v=b3;q=0.9”, “accept-encoding” => “gzip, deflate, br”, “accept-language” => “en-US,en;q=0.9”, “cache-control” => “max-age=0”, “connection” => “keep-alive”, “content-length” => “256338”, …}, host: “localhost”, method: “POST”, path: “/images”, peer: {{127, …}, 35770}, pid: #PID<0.552.0>, port: 4000, …}, “302 Found”, %{“cache-control” => “max-age=0, private, must-revalidate”, “content-length” => “130”, “content-type” => “text/html; charset=utf-8”, “cross-origin-window-policy” => “deny”, “date” => “Wed, 24 Mar 2021 21:24:32 GMT”, “location” => “/images”, “server” => “Cowboy”, “set-cookie” => […], …}, ImageerWeb.Endpoint.HTTP, -576460733935650229, :undefined, -576460733934302964, -576460733901628811, -576460733875939491, -576460733875939491, %{…}, …}}, “POST”, :“HTTP/1.1”, :undefined, :undefined, 0, []}], [{:child, #PID<0.581.0>, 10, 5000, :undefined}, {:child, #PID<0.573.0>, 9, 5000, :undefined}]}, 9, [{:response, “302 Found”, %{“cache-control” => “max-age=0, private, must-revalidate”, “content-length” => “130”, “content-type” => “text/html; charset=utf-8”, “cross-origin-window-policy” => “deny”, “date” => “Wed, 24 Mar 2021 21:24:32 GMT”, “location” => “/images”, “server” => “Cowboy”, “set-cookie” => ["_imageer_key=SFMyNTY.g3QAAAACbQAAAAtfY3NyZl90b2tlbm0AAAAYLXkwSGtPc0FWYU5HYWd5dzRtYnNmSElWbQAAAA1waG9lbml4X2ZsYXNodAAAAAFtAAAABGluZm9tAAAAG0ltYWdlIGNyZWF0ZWQgc3VjY2Vzc2Z1bGx5Lg.WprgZRVN3tAJjywzi0yuIop8LaAuoyIulwnpw5o52MU; path=/; HttpOnly"], “x-content-type-options” => “nosniff”, “x-download-options” => “noopen”, “x-frame-options” => “SAMEORIGIN”, “x-permitted-cross-domain-policies” => “none”, “x-request-id” => “Fm9kTP69U-EPDiIAAABF”, “x-xss-protection” => “1; mode=block”}, [“You are being <a href=”/images">redirected.", “<iframe hidden src=”/phoenix/live_reload/frame">", “”, “”]}]], [file: ‘/var/www/apps/imageer/deps/cowboy/src/cowboy_http.erl’, line: 954]}, {:cowboy_http, :loop, 1, [file: ‘/var/www/apps/imageer/deps/cowboy/src/cowboy_http.erl’, line: 254]}, {:proc_lib, :init_p_do_apply, 3, [file: ‘proc_lib.erl’, line: 226]}]}