Help with mix deps.get in Mac OS 10.13.6 High Sierra

This is a similar problem to I need help with 'mix deps.get' command
but I tried updating brew and reinstalling Erlang and elixir still its not working for me.

erlang otp 21
elixir version 1.7.3

mix deps.get

Could not find Hex, which is needed to build dependency :jsex

Shall I install Hex? (if running non-interactively, use “mix local.hex --force”) [Yn] Y

(no response)
Any other idea why its not working?

Have you tried mix local.hex --force? How long is it not responding? How are you connected to the internet? Firewalls, proxies or something else that might interfere?

mix local.hex --force never responds for me.
I don’t think firewalls and proxies will be interferring as I tried using my mobile wifi connection which dnt have any firewalls and proxies that can interfere.

On a mobile data plan most providers do actually a lot… but as the symptoms are the same on mobile and regular data plan, I assume it’s related to your computer.

Therefore I’m out of ideas at this point. Someone else has to take over.

This has also been posted on Elixir’s issues tracker:

1 Like