Helper references in Phoenix 1.3

Simple question. I’ve tried to upgrade to Phoenix 1.3.
I tried to follow the instructions to the letter :slight_smile:

These expressions are throwing errors when I come to run mix phx.server:

  use MyApp.Web, :view
  use MyApp.Web, :controller

I cannot find a reference to changing them in the instructions. Should they be changed or do they point to a problem elsewhere in the changes I’ve made?

If you followed the instructions from this gist, there’s a “Move your root-level web/ directory to lib/app_name_web, and migrate to new Web namespace” section.

Did you change MyApp.Web to MyAppWeb in your lib/my_app_web.ex?

All fixed. I created a new app and compared things. Not sure what fixed it, but this is the correct form

  use MyAppWeb, :controller

Now, my next challenge - where’s the Model gone!

On zsh you can use grep and a recursive glob:

grep "defmodule MyAppWeb do" **/*.ex

You have to hope then though, that you did not miscounted spaces :wink: