Https://repo.hex.pm/ - AccessDenied

If I naviage to the URL

https://repo.hex.pm/

I get the following error message:


<?xml version="1.0" encoding="UTF-8"?>
<Error><Code>AccessDenied</Code><Message>Access Denied</Message><RequestId>62E4910497DE61FC</RequestId><HostId>N7zoqvXlKqqBXH/F458zb0NR2R8OAFKcbq5zBAEvYsN5p9j7RpGyQM321hG001/RAPh+YqHetMc=</HostId></Error>

Is this normal? Have tried from my PC at home, as well as from my PC in the office, and both have different providers. Neither have a proxy set in the Ubuntu WSL. Both use different DNS servers.

Here the specific error:

$ mix local.hex --force
** (Mix) httpc request failed with: {:failed_connect, [{:to_address, {'repo.hex.pm', 443}}, {:inet, [:inet], :nxdomain}]}

Could not install Hex because Mix could not download metadata at https://repo.hex.pm/installs/hex-1.x.csv.

$ HEX_MIRROR=https://cdn.jsdelivr.net/hex mix local.hex
** (Mix) httpc request failed with: {:failed_connect, [{:to_address, {'cdn.jsdelivr.net', 443}}, {:inet, [:inet], :nxdomain}]}

Could not install Hex because Mix could not download metadata at https://cdn.jsdelivr.net/hex/installs/hex-1.x.csv.

I have been setting up a new Ubuntu for Elixir tests, and this used to work in the past on both machines, but is now failing, so I am a little usure what might be the cause.

Erlang 22.2.1
Elixir 1.9.4-opt-22
Ubuntu 18.04 LTS

How do you navigate there? By your browser? Especially if you use one from Windows, it might be setup totally different from what the WSL actually used.

Looks like your DNS were unable to resolve the name.

Are you perhaps behind a proxy?

Thanks for responding.

I entered https://repo.hex.pm/ directly in my Windows Chrome browser, on both Windows 10 machines with a Ubuntu 18.04 WSL running on both. This gave me the “Access denied” error. But the root problem is that I cannot install local.hex in mix, and I tought this error message was a symptom.

On both machines (Ubuntu 18.04 LTS on WSL Windows 10) I am not behind a proxy.

rb@RB-HOME:~$ ping repo.hex.pm
PING dualstack.f2.shared.global.fastly.net (151.101.2.2) 56(84) bytes of data.
64 bytes from 151.101.2.2: icmp_seq=1 ttl=54 time=13.0 ms
64 bytes from 151.101.2.2: icmp_seq=2 ttl=54 time=12.3 ms

The name can be resolved.

Manually downloading a file from the site works:

rb@RB-HOME:~$ wget https://repo.hex.pm/installs/hex-1.x.csv
--2019-12-23 17:07:36--  https://repo.hex.pm/installs/hex-1.x.csv
Resolving repo.hex.pm (repo.hex.pm)... 151.101.2.2, 151.101.66.2, 151.101.130.2, ...
Connecting to repo.hex.pm (repo.hex.pm)|151.101.2.2|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 19738 (19K) [text/csv]
Saving to: ‘hex-1.x.csv’

hex-1.x.csv                   100%[=================================================>]  19.28K  --.-KB/s    in 0.01s

2019-12-23 17:07:41 (1.61 MB/s) - ‘hex-1.x.csv’ saved [19738/19738]

Does this give you any information where to start looking for the cause of the issue?

If I go to repo.hex.pm it says access denied.

You might want to look into trying out minirepo,
at least you have some control. Likewise, I get
same result you reported from firefox on archlinux.

I sent an email to support at hex - yesterday; No response.
The homepage to hex.pm is poison
to brave, google-chrome browser. Search
in text bar and browser crashes instantly.


http://blog.plataformatec.com.br/2019/07/announcing-minirepo-a-minimal-hex-server/
https://github.com/wojtekmach/mini_repo

Ok, the issue here was my anti virus solution on Windows (webroot) blocking ports in the WSL, but not telling me about this blocking. This has never happened in the past, but, I guess there is always a first time. Turned off my anti virus, and everything works fine, turned it on again, and then the error is reproducable.

Thanks to everyone that had a look at this topic.

1 Like