I need help with 'mix deps.get' command

I am doing a elixir tutorial and trying to install ex_doc like the tutor says.
After I put in the module name in the .exs file
And execute “mix deps.get”
I get this error message

Could not find Hex, which is needed to build dependency :ex_doc
Shall I install Hex? (if running non-interactively, use: “mix local.hex --force”) [Yn]
Assertion failed: (ctx), function digest_update, file /BuildRoot/Library/Caches/com.apple.xbs/Sources/boringssl/boringssl-109.50.14/apple/crypto/digests.c, line 49.
Abort trap: 6

Whether I enter Y or n, it does not work.
It’s frustrating.
Thank you very much for help in advance.

Did you try

mix local.hex

by itself?

This looks like if you are on a Mac.

There have been issues because of apple switching the SSL libraries in the past.

From what I remember, upgrading bew and then removing erlang and elixir and reinstalling them worked for most people.

Yes I did and It still didn’t work.

Have tried turning it on and off again? Well, I mean doing the re-installation dance as proposed by me? If not, please give us more information about your system, like operating system and its version, kernel, elixir version, erlang version, installation sources, etc.

No I have not tried to upgrade and reinstall.
Did you mean upgrading brew?
How do you do all that?(removing erlang and elixir and reinstalling)

I am using macOS High Sierra 10.13.6
I am using Elixir 1.4.2
Erlang version looks like 19

How you update brew you need to know as a user of brew or ask their manual. The same is for reinstalling other software. You should upgrade Erlang and elixir anyway, you are 2 years behind.

1 Like

I usually just call brew update && brew upgrade && brew cleanup. Note that it would update and upgrade all packages installed with brew on your system, but that shouldn’t be a problem.

1 Like

I reinstalled brew and elixir.
Now it’s working!
Thanks a ton.


I had a similar issue until I discovered that Little Snitch was silently blocking my connections.

1 Like