Mac browsers can't resolve any .pm domains

Hi all,

Hopefully someone has had this before because it’s something that’s been driving me crazy for a while now.

Some time ago, not sure exactly when, I noticed that stopped opening on my Mac. I use Firefox but this happened on all browsers and even on curl. The behaviour is that the domain is not resolved and eventually the connection times out even though when using dig it does resolve perfectly fine. To add to the confusion this only happens on my specific Macbook, it does not happen on any other device on my network all of them configured in the same way, I have a Raspberry Pi with Pi-Hole installed as a DNS resolver.

I’ve also noticed this is not something that happens only for but for all .pm domains, i.e., the reference page for the TLD, fails to resolve as well. I’ve tried changing the DNS server on my machine to speak directly to and to no avail. I also tried clearing the OS X DNS cache and other DNS related techniques with no luck.

I’ve been working around the issue by hardcoding the IP into my /etc/hosts but obviously it starts failing as soon as the IP changes.

Any ideas on what could possibly be wrong? I’m completely stumped.


fwiw works fine here on mac… using - maybe related to hardcoded IPs in hosts - or some ttl/cache issue on the Pi-hole… is indead down… but also has it as down - so surely not related to a local issue…


I recommend you to use DNS over HTTPS.

1 Like