Missing essential processes in Nerves system

nerves
troubleshooting
#1

I built a Nerves system for the first time and installed to a Raspberry Pi. The system booted and I could interact with the Elixir shell.

But there are no network devices. When I try to investigate that, commands fail because essential processes are not running.

For example, the uname command from Toolshed fails because the Nerves.Runtime.KV process is missing, and the commands in Nerves.Network fail because the SystemRegistry processes are not running. I have also got some message that the Logger application is not running.

Does anyone have any idea what can have gone wrong or how I can further investigate this problem?

Here are the facts about my configuration:

My Raspberry Pi is a Model 3B+. My host is a Mac running macOS Mojave (10.14.5). Erlang/OTP is 21.3.8.2 and Elixir is 1.8.2. I used brew to install the needed packages as mentioned in the Nerves documentation.

The project I used was the hello_network example from the nerves_examples repository. I have tried it both without modifications and modified for wired Ethernet and Wireless. The same essential processes seem to be missing in each case.

One message that could be relevant is printed after the shell is started:

uevent: write: Broken pipe
2 Likes
#2

Thanks for the report. Sorry for the trouble. I’m testing this out right now. It’s possible we accidentally deleted a config entry or something.

2 Likes
#3

This seems to be a breakage relating to nerves_runtime. Downgrading the package fixed the issue. For now you can downgrade:

      {:nerves_runtime, "~> 0.9.5", targets: @all_targets},

I’m working on a proper fix.

3 Likes
#4

Hi @bjorng

Thanks for reporting this issue, indeed there was a bug that hit our initialization sequence in nerves_runtime. We have fixed this in v0.10.1. You can update to this version by setting the nerves_runtime dependency in your mix file to

{:nerves_runtime, "~> 0.10", targets: @all_targets}

Then run mix deps.update nerves_runtime. Let us know how things work out for you :slight_smile:

2 Likes
#5

That solved the problem. Thanks for the quick fix!