Mix phoenix.server throwing error on new project (Windows 7)

Hi all,

I am getting the following when creating a new project and when i try and run the project (with iex -S mix phoenix.server)

[info] Running Pathwebrelay.Endpoint with Cowboy using http on port 4000
Interactive Elixir (1.2.6) - press Ctrl+C to exit (type h() ENTER for help)
iex(1)> 20 Jun 20:54:44 - ←[31merror←[0m: Compiling of web\static\js\socket.js failed. Couldn’t find preset “c:\Users\
tom\IdeaProjects\pathweb\apps\pathwebrelay\node_modules\babel-preset-es2015” relative to directory “web\static\j
s” ; Compiling of web\static\js\app.js failed. Couldn’t find preset “c:\Users\tom\IdeaProjects\pathweb\apps\pathwe
brelay\node_modules\babel-preset-es2015” relative to directory “web\static\js”

This worked yesterday!! I have tried using the install dependencies Y and N following with npm install etc - still no joy.

Any ideas? Is this a real problem or am i doing soemthing stupid - following programming phoenix P21

Apologies for posting - RTFM!!!

I wasusing the LTS version of node JS which was 4.x rather than the latest which was 6.x

It was somethign stupid after all!!! :smiley: