My library on github isn't getting found when I run my app which uses it

I have my custom library on github and a separate project. A library doesn’t found when I run a project.

The mix file of the project:

  # [................]
  {:my_lib, git: ""}

It’s been downloaded and compiled succusessfully, according to the logs. However, when I run the project and call a module from the library, the module won’t get found as if it didn’t exist.

And also, this:


run via “iex -S mix phx.server” will throw an exception “the module not found or private”

I’ve removed the dependencies and reinstalled them. To no avail.

1 Like

It’s hard to say without seeing the code of the Module in question. A quick way to verify would be to look in the deps directory after running mix deps.get. you should be able to see your library, and verify all the files are there. Also, what version of Elixir are you running?

it’s there

the 1.9

Is it a public library or a private library?

Is the module you are expecting to exist a GenServer? If so, you need to make sure it is started correctly and registering the name you expect.

Do you have tests for your library? May want to duplicate your startup procedure for your app, and test that everything starts up properly,

1 Like