New Test module naming convention in ExUnit 1.4.5?

I googled doctest to get some nice overview on it, and found this page:

In it, it creates test modules with this naming convention:

defmodule MyModule.Test

Where before it used to be:

defmodule MyModuleTest

In my particular codebase, I have working tests that are named like:

defmodule Foobar.User.Authentication do

# and the tests...
defmodule Foobar.User.AuthenticationTest do

Should I switch to use the .Test at the end of my test modules?

No. It is a mistake in the docs that I will fix in master and backport. Thank you.


Thanks Jose