Observer error on Windows11

I can open observer gui in iex shell. But when I run “iex -S mix” to start an app and run “:observer.start”, it shows:

    {:observer_backend, :sys_info, [], []},
    {:observer_sys_wx, :init, 1, [file: ~c"observer_sys_wx.erl", line: 50]},
    {:wx_object, :init_it, 6, [file: ~c"wx_object.erl", line: 404]},
    {:proc_lib, :init_p_do_apply, 3, [file: ~c"proc_lib.erl", line: 240]}

This is my mix.exs file:

defmodule Servy.Mixfile do
  use Mix.Project

  def project do
      app: :servy,
      version: "0.1.0",
      elixir: "~> 1.15",
      start_permanent: Mix.env() == :prod,
      deps: deps()

  # Run "mix help" to learn about applications.
  def application do
      extra_applications: [:logger, :eex, :observer, :wx]

  # Run "mix help deps" to learn about dependencies.
  defp deps do
    [{:poison, "~> 5.0"}]

Elixir (1.15.0) and Erlang/OTP 25 on Windows 11

Add :runtime_tools to extra_applications.

Seems like 1.15 requires these to be defined. Worked without them in 1.14.5.

@josevalim is this an intended consequence of the compiler changes in 1.15?

1 Like

Thank you! It works!