One more failed attempt to try nerves this weekend

I have a spare rpi zero (not w) which ive got raspbian running with wifi enabled with a usb wifi dongle. however i have no idea how to put my wifi drivers on nerves. I can’t find any documentation on how to do it either or any one who has written about it doing it. one day it will just magically work or i’ll be able to buy an rpi w again.

it shoudn’t really by this difficult. ive edited the conf files correctly and i even saw one of my usb dongle blinks (and i know nerves supports teh driver 2800 rtl) but still no luck. i dont want to use that dongle because it has a faulty usb connector (it melted and overheated).

there are instructions for building a custom linux system here: Customizing Your Own Nerves System.
You can add support for different WiFi chipsets under Hardware Handling -> Firmware -> linux-firmware -> WiFi Firmware when running make menuconfig.
By default only Ralink rt27xx/rt28xx/rt30xx is enabled.

Thanks, i can’t find Hardware Handling anywhere in the menu.

edit. found it, it was under Target packages → Hardware handling → Firmware → linux-firmware

Aaand it wouldn’t compile through, died on an error about some C file, which i googled and requires manually patching a bunch of places. Not for me. I will wait til this thing is ready for prime time. Not like i’m using some exotic system, its a plain vanilla Ubuntu 22.04 install on amd64.

Hmm, on macOS it uses a docker container, which works without a problem.
Not sure if you can force it using docker on Ubuntu.