Phoenix 1.4 and Coherence are not friends anymore

Recently I updated to Phoenix 1.4 and for a new project I need authentication so I tried to use Coherence as always but this happened:

Failed to use “ecto” (version 3.0.1) because
coherence (version 0.5.2) requires ~> 2.0
ecto_sql (version 3.0.0) requires ~> 3.0.0
phoenix_ecto (version 4.0.0) requires ~> 3.0
mix.lock specifies 3.0.1

I checked the repo and there is a discussion and even a pull request to update but unfortunately, I have to start working on this app today and can’t wait for the merge.

Does anyone know a solution to the dependency issue above or can recommend something similar to Coherence?

1 Like

You can still use ecto 2.0, just downgrade phoenix_ecto

Additionally, swoosh seem to not be able to run its local server when trying to use Ecto 3.0. :frowning:

Have you tried overriding it by adding this to your mix file ?

{:ecto, "~> 3.0", override: true},

Yes. But coherence depends on timex_ecto which cannot compile under Ecto 3.0.

1 Like