Phoenix Gen Auth Dependecy Fail

I added the phx_gen_auth to my dependecies and i get the error below after running mix deps.get

After trying the suggestion given(mix deps.update and mix.deps.unlock), I still cant get my program compiled as it gives more errors.

I updated my phx_gen_auth to 0.6.0 but it stills insits it requires Phoenix 1.5.2 while am
using Phoenix 1.6.2. Do i have to down grade?
Thanks! :smiley:

Remove the dep from your mix.exs file. Phoenix 1.6 ships with it by default. I think the two deps are conflicting.

1 Like