Phoenix Live View 0.16-dev

I wanted to get really adventurous - and - tried to create a new application with the latest and greatest versions of Phoenix & Phoenix LiveView. So I used

{:phoenix, github: "phoenixframework/phoenix", override: true},
{:phoenix_live_view, github: "phoenixframework/phoenix_live_view", override: true},

When I did a mix deps.get, I got an error saying phoenix_html is diverging. Then I replaced

{:phoenix_html, github: "phoenixframework/phoenix_html", override: true},

Now, the deps are correctly installed. However, when I run, mix phx.server I am getting an error unknown live option :session in file router.ex
Any work arounds?


Is this the error you’re getting?

== Compilation error in file lib/hello_web/router.ex ==
** (ArgumentError) unknown live option :session.

Supported options include: :container, :as, :metadata, :private.

Got: [session: {Phoenix.LiveDashboard.Router, :__session__, [nil, false, {HelloWeb.Telemetry, :metrics}, nil, [], nil, nil, nil]}]

    (phoenix_live_view 0.16.0-dev) lib/phoenix_live_view/router.ex:389: anonymous fn/1 in Phoenix.LiveView.Router.validate_live_opts!/1
    (elixir 1.12.2) lib/enum.ex:930: Enum."-each/2-lists^foreach/1-0-"/2
    (phoenix_live_view 0.16.0-dev) lib/phoenix_live_view/router.ex:363: Phoenix.LiveView.Router.validate_live_opts!/1
    (phoenix_live_view 0.16.0-dev) lib/phoenix_live_view/router.ex:343: Phoenix.LiveView.Router.__live__/4
    lib/hello_web/router.ex:39: (module)
    (stdlib 3.15.1) erl_eval.erl:685: :erl_eval.do_apply/6
    (elixir 1.12.2) lib/kernel/parallel_compiler.ex:319: anonymous fn/4 in Kernel.ParallelCompiler.spawn_workers/7

Switching phoenix_live_dashboard to the current unreleased version as well seems to be fixing it for me:

{:phoenix_live_dashboard, github: "phoenixframework/phoenix_live_dashboard", override: true},

Also, you probably did this as well, but for anyone else reading this: for trying out new unreleased phoenix versions it’s good to use the installer from phoenix master. You can install it by following instructions from in the installer directory


This worked.