Phoenix project creation error and on ubuntu 16.04

Hi guys i’m receiving this error

Fetch and install dependencies? [Yn]

  • running npm install && node node_modules/brunch/bin/brunch build
  • error command failed to execute, please run the following command again after installation: “npm install && node node_modules/brunch/bin/brunch build”

We are all set! Run your Phoenix application:

$ cd discuss
$ mix deps.get
$ mix phoenix.server

You can also run your app inside IEx (Interactive Elixir) as:

$ iex -S mix phoenix.server

Before moving on, configure your database in config/dev.exs and run:

$ mix ecto.create

i removed nodejs and try to re install it, i tried to install brunch module globally, locally, nothing…

how can i fix it?



guys, ok, if i don’t install the dependencies and then i run the commands to install it it work.

But when i was on the mac it worked with the auto installation, there is a way to do that also on ubuntu? so when it ask to me if i want to install dependencies, answering Yes it does everything automatically?


1 Like

That’s weird. How did you (re)install Node.js? What’s the output of node --version and npm --version?


i use it sudo apt-get remove nodejs and then the same for npm.
i re install it following the doc on node site, and i have v6.9.5 for node and 3.10.10 for npm.

Everything works now but the only thing is that error if i try to install dependencies at the beginning when mix ask to me that.

1 Like

I just assumed that under some combination of console state + whatever major/minor/patch verions of Node/NPM/Erlang/IEx are interacting at that point, it just doesn’t work without running it as a seperate step. It happens every so often to me - at the minute, with newest versions, works fine, on various other versions, had to run seperate step. I get that isn’t much help. Every time it happened, I always felt there were far too many possible causes for me to feel it was worth bothering investigating vs. either doing it in two steps, or upgrading to newest version of everything & trying again, one of which always worked.

Note I’m on OSx, and I’ve see it happening on WIndows as well; at that specific point in time there seem to be several plates spinning and on some versions of {whatever} the process breaks down


I’m on ubuntu 16.04 LTS, but the problem was a bug in the older version of phoenix, that they solve it in the new version. I found that my problem was only that i didn’t reboot ubuntu, so i think was a problem with some path not updated. Now it work fine.