Phoenix - Seeding database from json file

I’m trying to seed data to phoenix database using json file.
Let’s say I have at priv/repo/seeds/some_file.json in my phoenix directory.

# priv/repo/seeds.exs
json_file = "#{__DIR__}/seeds/some_file.json"

with {:ok, body} <-,
     {:ok, json} <- Jason.decode(body, keys: :atom) do
  # insert to db
  err ->

But i got the following error when running the script :

(UndefinedFunctionError) function Jason.decode/2 is undefined (module Jason is not available)

I can see Jason dependency in my mix.exs file but it doesn’t seem to be working inside priv/repo/seeds.exs file. Or is there any other way / common patterns to seed phoenix app database from external file (json/csv) ?

1 Like

Have you ran the mix deps.get command after adding Jason to your mix.exs file?

It should be keys: :atoms btw (note the “s” at the end).

Hi @dimitarvp, thanks for the reply.
I already ran mix deps.get and set keys: :atoms. But the same problem still occurs.
I also create another elixir module inside priv/ directory and it also cannot use Jason (same problem).
Here’s additional error message:

** (UndefinedFunctionError) function Jason.decode/2 is undefined (module Jason is not available)
    Jason.decode("...long valid json body here...")
priv/repo/seeds.exs:21: (file)
    (elixir 1.10.3) lib/code.ex:926: Code.require_file/2

But I can use the library just fine from lib/ directory. :frowning:

Do you have jason in only one mix environment by any chance? Can you show how you are importing it in mix.exs?

EDIT: For good measure, just delete _build and deps directories and do mix do deps.get, compile after?

Already tried it, same result. :frowning:

For now, I got it working by importing manually the required files from deps folder.
Add the following lines in seeds.exs does the trick.

Code.require_file("codegen.ex", "./deps/jason/lib")
Code.require_file("decoder.ex", "./deps/jason/lib")
Code.require_file("encode.ex", "./deps/jason/lib")
Code.require_file("encoder.ex", "./deps/jason/lib")
Code.require_file("formatter.ex", "./deps/jason/lib")
Code.require_file("fragment.ex", "./deps/jason/lib")
Code.require_file("helpers.ex", "./deps/jason/lib")
Code.require_file("jason.ex", "./deps/jason/lib")

I guess it has something to do with files priv/ directory are not compiled by design.

That’s really strange and you should definitely not have to resort to such hacks but I can’t figure out how is this supposed to be done properly.

Still, mind copy-pasting your mix.exs file? I am think it might be something related to the elixirc_paths option in it but I might be wrong.

At this point you should IMO just make a normal module inside your app – with an .ex file extensions – because such gymnastics with Code.require_file are brittle and you are just one dependency version away from that code breaking. But then it raises the question if you should have seeding code shipped with your production code (which I think you shouldn’t).

Here’s my mix.exs content:

defmodule MyApp.MixProject do
  use Mix.Project

  def project do
      app: :myapp,
      version: "0.1.0",
      elixir: "~> 1.7",
      elixirc_paths: elixirc_paths(Mix.env()),
      compilers: [:phoenix, :gettext] ++ Mix.compilers(),
      start_permanent: Mix.env() == :prod,
      aliases: aliases(),
      deps: deps()

  # Configuration for the OTP application.
  # Type `mix help` for more information.
  def application do
      mod: {MyApp.Application, []},
      extra_applications: [:logger, :runtime_tools]

  # Specifies which paths to compile per environment.
  defp elixirc_paths(:test), do: ["lib", "test/support"]
  defp elixirc_paths(_), do: ["lib"]

  # Specifies your project dependencies.
  # Type `mix help deps` for examples and options.
  defp deps do
      {:bcrypt_elixir, "~> 2.0"},
      {:phoenix, "~> 1.5.1"},
      {:phoenix_ecto, "~> 4.1"},
      {:ecto_sql, "~> 3.4"},
      {:postgrex, ">= 0.0.0"},
      {:phoenix_html, "~> 2.11"},
      {:phoenix_live_reload, "~> 1.2", only: :dev},
      {:phoenix_live_dashboard, "~> 0.2.0"},
      {:telemetry_metrics, "~> 0.4"},
      {:telemetry_poller, "~> 0.4"},
      {:gettext, "~> 0.11"},
      {:jason, "~> 1.0"},
      {:plug_cowboy, "~> 2.0"},
      {:phx_gen_auth, "~> 0.3.0", only: [:dev], runtime: false},
      {:credo, "~> 1.4", only: [:dev, :test], runtime: false}

  # Aliases are shortcuts or tasks specific to the current project.
  # For example, to install project dependencies and perform other setup tasks, run:
  #     $ mix setup
  # See the documentation for `Mix` for more info on aliases.
  defp aliases do
      setup: ["deps.get", "ecto.setup", "cmd npm install --prefix assets"],
      "ecto.setup": ["ecto.create", "ecto.migrate", "run priv/repo/seeds.exs"],
      "ecto.reset": ["ecto.drop", "ecto.setup"],
      test: ["ecto.create --quiet", "ecto.migrate", "test"]

Yes, I agree about the hacky solution. But I also want my seeding scripts in the priv/ directory because IMO it doesn’t belong in lib/.

Usually, I create the data using simple elixir data structures or randomize data using loop in seeds.exs file. But I was wondering how’s the case when the seed data should came from json / csv file.

How are executing the seeds file? Is it with mix run priv/repo/seeds.exs?

1 Like

@axelson Actually yes, this is definitely the issue on my case.
Silly me, I was previously using elixir ./priv/repo/seeds.exs.

Thank you.

1 Like

Yup, that would do it! Glad you got it resolved :slight_smile:

1 Like