Phoenix server error with hex (erlang won't install ? )

I run the phoenix server and I get this error:

~/Desktop/phoenix_sandbox/app$ mix phx.server
==> gettext
Compiling 1 file (.yrl)
/usr/lib/erlang/lib/parsetools-2.1.8/include/yeccpre.hrl: no such file or directory

could not compile dependency :gettext, "mix compile" failed. You can recompile this dependency with "mix deps.compile gettext", update it with "mix deps.update gettext" or clean it with "mix deps.clean gettext"

I tried running the commands the error mentioned and it just makes me go in circles - I end up with the same error. I tried installing “parsetools” and it hasn’t worked.

I’m on Ubuntu (Pop OS)

It seems as if your Erlang is missing the parsetools.

How have you installed Erlang, which version of it, and have you also installed related packages?

Yes, it doesn’t work.

More info:

What exact version of ubuntu are you on? (check /etc/os-release)

You put “popOS” in parenthesis, so are you using Ubuntu or a fork/derivation of it? Have you checked if the esl-erlang is even compatible with that fork/derivation?

Distributor ID: Ubuntu
Description: Pop!_OS 18.10
Release: 18.10
Codename: cosmic

18.10? If versioning follows upstream (ubuntu) then you should update or downgrade to next LTS version that you can use.

18.10 does not receive any updates anymore since 19.10 has been released.

Hey, I got this issue on 20.04 which persisted after I upgraded to this:

ID_LIKE=“ubuntu debian”
PRETTY_NAME=“Pop!_OS 20.10”

Is there a fix on pop for this?

Install whatever provides erlangs parsetools for your system.

This is the usual way to go.

For a development machine is suggest to use asdf-vm to install runtimes and compilers. The asdf provided erlang comes with all of its core applications.