Problem with the SSL CA cert (path? access rights?) github

I can clone this url using git client just fine:

git clone

But when I include the above uri in my mix.exs file like this:

{:dep_from_git, github: “”, tag: “0.10.0”}

rollingw@rollingw-Lenovo-B570:~/elixir-and-phoenix-bootcamp/identicon$ mix deps.get

Does the mix tool require some type of cert I’m not aware of?


I think for :github you need to provide just the path, not the full url.

{:dep_from_git, github: "erlang/egd", tag: "0.10.0"}

You can also try using :git

{:dep_from_git, git: "", tag: "0.10.0"}

For more:


Tried this syntax too:

{:ex_doc, "~> 0.12"},
{:dep_from_git, github: "erlang/egd", tag: "0.10.0"}

Same deal:

rollingw@rollingw-Lenovo-B570:~/elixir-and-phoenix-bootcamp/identicon$ mix deps.get

  • Updating dep_from_git (
    fatal: unable to access ‘’: Problem with the SSL CA cert (path? access rights?)
    ** (Mix) Command “git --git-dir=.git fetch --force --quiet --progress --tags” failed

I tried to fetch this dependency on my Windows as:

  • {:dep_from_git, git: "", tag: "0.10.0"} and
  • {:egd, git: "", tag: "0.10.0"}

All works correctly, maybe it is a problem with the permission in your directory

Are you running behind a Firewall or a Proxy that uses custom self signed certificates?


Well… this is questionable… o.O

Either the certificate store on that computer itself is way out of date (embedded system or so?), or something is hijacking your connection (look at what @Exadra37 said), or some libraries on the OS itself are corrupt or so. ^.^;

1 Like