Currently Phoenix uses “weird” naming convention that controllers (and other modules) are stored in paths like
lib/app_web/controllers/foo_controller.ex and are named
AppWeb.FooController which for me is:
- Unnatural as I would expect it to be named after path, which is common practice in almost all other Elixir libraries.
controllerpart in path.
Instead what I am proposing is to change that to:
AppWeb.Controllers.Fooas module name
This also results in IMHO cleaner routing, as (when using scopes) we can do:
scope "/", AppWeb.Controllers do resource "/foos", Foo end
Which skips IMHO redundant
Controller part of the name.