Snipline - Shell command organiser

phoenix
#1

Hi :slightly_smiling_face:,

Thought I’d share this here as I’ve been building my latest project with Elixir + Phoenix. The project is called Snipline ( https://snipline.io/ ).

It started off as a side project to help myself manage useful shell commands that I found on the web. I wanted to be able to search and copy commands easily and change paths and parameter options for each environment.

I chose to use Elixir and Phoenix for the API as I’ve been using this stack on other small projects for a while now and I really enjoy both the language and the framework. I’m also considering some real-time features in the future and I know I’m in good hands with Elixir.

I wrote in a bit more detail some of the pain points of the initial build here if anyone is interested.

Anyway, I’d love to hear some feedback on it if anyone’s interested!

5 Likes
#2

Woah! That’s a really useful application. I’m really thinking about signing to it, one question though: have you thought about selling it like an app on Mac App Store instead of a subscription based thing?

I mean, I like subscription based stuff too, but I particularly hate clicking the Start 30 days trial, I think the “freemium” pricing model will make your product a lot more popular. :smiley:

1 Like
#3

Thanks for checking it out @kelvinst :slightly_smiling_face:

Originally, when I was first planning the app, I considered making a native app which used iCloud for syncing data.

I decided against because I wanted the app available on all platforms, and I wanted to be able to sync between devices. I have two Apple IDs (One work, one personal) and I find it frustrating having to buy apps on both, and even then iCloud sync would not work between the two.

Is it the wording “Start 30-day trial” that’s the issue or the subscription in general? The subscription helps support development and keeps the server up and running :grinning:. Maybe in the future I might look into a freemium option or a free “lite” app.

That said, if you’re interested want more time to try it out send me a PM and I’ll gladly extend the trial for you :slightly_smiling_face:

2 Likes
#4

Yeah, but it’s basically a personal feeling, not something proved to be bad. I mean, I hate trials, that’s it.

I imagined that and totally understand. :smiley:

That would be awesome.

Cool! I’ll try it out and let you know! Thanks!

#5

Very cool, nice to see Linux support. I’m def going to give it a try and see if I like it more than editing my .zshrc file, seems more powerful.

#6

@Artemitch The .deb package is broken, it creates a dangling symlink

The symlink should point to /usr/lib/snipline/Snipline, also I don’t believe /usr/lib is the proper location for a program binary.

Also any plans at setting up a PPA so manual updates are not needed?

1 Like
#7

Thanks for trying it out @frigidcode :grinning:

I think this in an Electron issue. I wrote some installation instructions for Linux which may help but I’m waiting on a bug fix really.

This sounds like a great idea, it’s not something I’ve tried before but I’ll take a look :slightly_smiling_face:.

#8

The instructions were followed however they don’t prevent the issues I am seeing upon install. Inside the .deb the symlink is broken (data/usr/bin within data.tar.gz). Are the .deb files being packaged by some sort of Electron script? Or are you rolling them by hand?

Also I do like the UI, nice job!

#9

The instructions were followed however they don’t prevent the issues I am seeing upon install. Inside the .deb the symlink is broken ( data/usr/bin within data.tar.gz ). Are the .deb files being packaged by some sort of Electron script? Or are you rolling them by hand?

I’m using Electron Forge for packaging. I’ll take a look at my config and see if there’s something I can change to fix it.

Also I do like the UI, nice job!

Thanks! Wish I could take all the credit but I work with some very talented designers :slight_smile:

#10

I have fixed the symlink in the latest release :slightly_smiling_face:. Thanks for pointing out the issue, turns out I had my configuration slightly wrong. I’m still looking into PPAs and possibly Snapcraft for better updates on Linux.

2 Likes
#11

PPA’s, DEB’s, Snaps, flatpak’s, an asdf plugin (this one would be really easy to do and asdf is super popular in the erlang/elixir communities), etc… :slight_smile:

#12

Recent issue upon login is permission errors around /usr/lib/snipline/resources/app.

Error found when loading /etc/profile:

find: '/usr/lib/snipline/resources/app': Permission denied

I removed the app, I don’t have time for this at the moment but will check back and test more once I have free time again.

#13

I was under the impression asdf was more for languages rather than apps. Am I wrong?

I spent a good portion of Saturday trying to get the App set up with a PPA and Snapcraft, but unfortunately the documentation for doing this with Electron apps is sparse :slightly_frowning_face:. I will try AppImages next.

#14

I can’t say I’ve come across this error yet. Have permissions changed on your system lately?

The latest version should at least fix the symlink :slightly_smiling_face:

#15

Nothing has changed besides for installation of Snipline.

#16

Ok, I’ll try installing on a fresh VM and see if I can spot any issues.

#17

It was originally but it has grown a lot! :slight_smile:

#18

I am using Pop OS if you wanted to target my issue directly :wink:

#19

Thanks :slight_smile:, I’ve installed Pop OS and Snipline seems to be working fine.

There were a couple of issues, but I think this is more due to the fact that I was on a fresh Pop OS install. I had to install libconf-2-4 which also failed and required an sudo apt --fix-broken install.

After that, Snipline worked and I was able to search/open from the Activities area.

I’ll try restarting it a few times and see if the issue crops up then as well.