Suddenly unable to resolve mix dependencies

Hi there. Just wondering if anyone else is experiencing this at the moment?

I cannot seem to resolve any mix dependencies this evening. Never had any issues until now. It started with a Phoenix project but I quickly discovered that it applies to any dependencies, when I replicated the issue with a default mix project and tried to add plug and flow.

The strange thing, aside from this happening out of the blue, is I can access and browse packages without issue.

Is there a way to debug this via mix or the CLI in general? Thanks!


What is you Elixir version and OS ?

1 Like

Hi Lud. MacOS Mojave and Elixir 1.10.3

I’m witnessing some variant behaviour here.

I created a new project with mix new deps_test. Then I added a few random dependencies one by one.

FIrst, I added {:uuid, "~> 1.1"} with no issues.

Then, I added {:plug, "~> 1.10"} and got the following error:

** (Mix) Unable to find package plug_crypto in registry

I tried adding {:flow, "~> 1.0"} and got a similar error:

** (Mix) No package with name flow (from: mix.exs) in registry

Not really sure what’s going on here.

Trying to pull latest plug and flow with mix hex.package fetch and got some errors:

mix hex.package fetch plug 1.10.3
** (Mix) Checksum mismatch against registry (inner)


mix hex.package fetch flow 1.0.0
** (Mix) Checksum mismatch against registry (inner)

Got this to work using another mirror:

HEX_MIRROR= mix deps.get

Everything working fine now.

1 Like