The "vsn=d" query parameter causes Firefox to not cache assets

I am a Chrome user and have not noticed this because it does not exist on Chrome. When I used Firefox I found that it didn’t cache assets.
After some inspection, I found that it may be related to the query parameter “vsn=d”.

I want to remove the vsn query parameters to further verify, but I can’t seem to do that?

Interesting. Just found this:

1 Like

“works fine here”

can you show a screenshot? what FF version?

NB - if you reload in firefox it doesn’t use cache - hit enter in the adressbar…
also is “disable cache” enabled in your dev tools?

1 Like

Can you test my website? Address:

(I will hide the domain name after the problem is solved)

PS: I didn’t disable Firefox’s cache. This is also the case on my mobile Firefox.

works just fine… (hid your url…)


also - I suggest using something like - you get a 95% score… (you need to look into enabling gzip.)

all the best


OK, thank you. You let me know that the problem is with my browser. I tried to reset the Firefox settings and then update this post.

Doesn’t work for me either