Updating for ex_insights

I’ve been asked to get ex_insights set up on a slightly older application (we were using Phoenix ~> 1.3) I’ve been able to update Phoenix and Elixir to 1.4 and 1.10.4, respectively, but I’m still unable to install ex_insights because of a poison requirement. We were using :poison "~>3.1 but :ex_insights requires 4.0. The problem is phoenix_gon requires 3.0 so it seems that I now have this dependency clash between ex_insights and phoenix_gon specifically.
I’ve tried thee Mix suggestions, mix deps.unlock, mix.deps.update, and override: true.
Any suggestions on how I should proceed and or troubleshoot this issue?