Useless error message from exrm

So I export MIX_ENV=prod, then get deps, compile deps, compile–no errors from any of those steps, then this:

bash-4.1$ mix release
Building release with MIX_ENV=prod.
==> ERROR: "Failed to build release. Please fix any errors and try again."

Things are a little out of date on this box, Erlang 18.2 & Elixir 1.2.3. I’m going to update, but wondering if anyone has any insight into this failure.

I tried exrm myself for the first time today, and faced the same issue.

I expected that it was something I’d done myself, but as you’re having the same problem as well, maybe something really is broken.

In any case, it is indeed a very cryptic error message, so I hope that someone can shed some light here.

Updating Elixir to 1.2.5 (from 1.2.3) fixed it.

I should add that I still have no idea what the error actually was, but 1.2.5 is the only change between it not working and working.

Glad you got it working!

Now I only hope that I’ll get it working over here as well. As I already am on Elixir 1.2.5 this has to be a different problem then…

Does anyone know how to get more information from Exrm on what is wrong?

Have you tried mix release --verbosity=verbose? That might give you some further clues…

1 Like

Thank you! Using the verbose mode, it gives me the following final part:

===> Provider (resolve_release) failed with: {error,
==> ERROR: "Failed to build release. Please fix any errors and try again."