Which operating system do you develop on (Poll)

Another mix. I use Linux servers on EC2 and Heroku, but the laptop runs Windows (and I use Windows Subsystem for Linux to test on a server-like environment).

@michael_teter Have I mentioned Bash on Ubuntu on Windows too many times now? That, and buggy support for HiDPI monitors, is what drove me off Linux onto Windows.

Recent KDE substantially improved HiDPI support if you want to give the latest KDE NEON snapshot a try. I’m curious how it would work for you as I only have a 1980x1200 monitor.

1 Like

Does it allow one screen to be hidpi and the other to be normal?

Not a clue, I only have normal monitors. ^.^

Windows + Hyper-V Ubuntu VM, because some things just don’t compile under Windows :slight_smile:
Hyper-V is a beauty. I use it in fullscreen with Xubuntu, disabled compositor, can’t tell the difference.

Eh, have it at work on Win10, cannot every get it to work, always says not enough memory, even if I allocate just a measly 512megs to the VM. I’ve yet to get it to work… 16gigs of memory on the host.

OS X at work, Linux at home. Unless this job gifts me the MacBook Pro, then I might do more home develoment on it. But either way, our servers are Ubuntu, so Linux is at least the primary target in both cases. :slight_smile:

Are you sure you’re changing the right settings? I got a “not enough memory” when I set the setting on the screenshot too high.

Hyper-V is amazing, I even dedicated a separate USB NIC to it and the host OS can’t use it :slight_smile:

And then:

Have I mentioned that I really hate Windows?

Well beats me shrug. I’m new to this thing, but from your screenshot I think your VM is Generation 1, have you tried with Generation 2, and disabled secure boot?

Docker requires Gen1, not a clue of the differences other than secure boot crap (which needs to die off), not that docker can run anyway (it will not start either, same issue).

Not sure what’s happening on your system, the error on your screenshot shows the VM trying to use 1536 ram. I get the same error when I set ram to 80GB. I saw something about docker having settings for how much ram it uses from Systray icon, but I’m not sure that’s the problem if you have 16 bloody gigs :confused: windows 10 updates?! shrug

I would wait till ubuntu for windows comes out of beta and make sure it has all the features you need. The windows command line is an utter joke. It’s by far the biggest reason why Ubuntu has become my main driver at home when I’m not using my mac.

1 Like

For everyone who likes recent updates on a stable system at Linux:



KDE rules :slight_smile:


It does :slight_smile:

A proper integration rules also :stuck_out_tongue: :wink:

1 Like