ASDF not creating erlang on new mac update

Hello everyone, I am having an ASDF issue when installing Erlang 21.3. Here is the error I am getting.

The asdf_21.3 build has been deleted
Extracting source code
Building Erlang/OTP 21.3 (asdf_21.3), please wait...
Build failed.
configure: error:

  You are natively building Erlang/OTP for a later version of MacOSX
  than current version (12.1). You either need to
  cross-build Erlang/OTP, or set the environment variable
  MACOSX_DEPLOYMENT_TARGET to 12.1 (or a lower version).

make: *** No rule to make target `is_cross_configured'.  Stop.
make: *** No rule to make target `all'.  Stop.

Please see /Users/jack/.asdf/plugins/erlang/kerl-home/builds/asdf_21.3/otp_build_21.3.log for full details.

I am on (MacOs Monterey 12.1 and ASDF has not worked since I updated my mac. Installing Elixir works fine but Erlang is causing the issue. Any ideas? I’ve tried blowing everything up and reinstalling ASDF but that did not work.

You might experiencing this bug -

This was fixed in 2.2.4 - you can specify a kerl version using

export ASDF_KERL_VERSION="2.2.4"
asdf install  erlang 21.3

This worked for me!

1 Like

The best guide I found for installing Erlang and Elixir on an M1 Mac with ASDF is this one by Yamazaki Susumu. I recommend it especially because it makes use of all CPU cores. But I only tried it with the latest versions of Elixir and Erlang.

1 Like