Asdf SSL certificate error for elixir installs

I used asdf to install Erlang/OTP 22 and Elixir 1.9.4 a while back. I tried to install 1.10 this evening, and find that asdf doesn’t seem to be able to do anything as far as elixir goes (for example, it returns nothing when prompted to list all available packages). I uninstalled the elixir plugin and the version of elixir I had on my machine and then tried to reinstall, but all that did is leave me with no versions of elixir installed and a plugin that won’t install any. Some relevant output below. Obviously it looks like a problem with a certificate, but I’m not sure what to do with that.

For what it’s worth, I have no problems with the erlang plugin - I downloaded and built OTP 22.2.6 with no problems.

Appreciate any thoughts folks have.

vagrant@ubuntu-bionic:~$ asdf update
HEAD is now at 6207e42 Update version to 0.7.6
Updated asdf to release v0.7.6
vagrant@ubuntu-bionic:~$ asdf plugin-add elixir
Plugin named elixir already added
vagrant@ubuntu-bionic:~$ asdf list all elixir
vagrant@ubuntu-bionic:~$ asdf current
elixir         No version set for elixir; please run `asdf <global | local> elixir <version>`
erlang         22.2.1   (set by /home/vagrant/.tool-versions)
postgres       12.1     (set by /home/vagrant/.tool-versions)
vagrant@ubuntu-bionic:~$ asdf install elixir 1.9.4-otp-22
==> Checking whether specified Elixir release/reference exists...
==> Downloading 1.9.4-otp-22 to /tmp/elixir_build_jxIrYY/
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (60) SSL certificate problem: certificate is not yet valid
More details here:

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.
==> Copying release into place
unzip:  cannot find or open /tmp/elixir_build_jxIrYY/, /tmp/elixir_build_jxIrYY/ or /tmp/elixir_build_jxIrYY/

This usually indicates your local clock is not set correctly.

1 Like

My VM system time is off by a few days; a reset fixed this. Thanks!