AshJsonApi: Create relationship when creating resource

I have a resource, eg Post, where the post has many Authors. When creating a Post, there should be at least one (1) Author attached to the payload. I know the json api v1 spec does not really outline creating multiple resources at once, but I figured we should be able to regardless?

What I’ve tried so far:

  1. Passing the relationship in the relationships section of the body - This fails with stack
[error] GenServer #PID<0.767.0> terminating
** (FunctionClauseError) no function clause matching in anonymous fn/2 in AshJsonApi.Request.relationship_change_value/1
    (ash_json_api 0.33.1) lib/ash_json_api/request.ex:668: anonymous fn(:error, {:ok, []}) in AshJsonApi.Request.relationship_change_value/1
    (elixir 1.15.7) lib/enum.ex:4387: anonymous fn/3 in Enum.reduce/3
  1. Passing the relationship into the Post attributes when creating - This does not work, throws an invalid body because the Author attribute is not an attribute on the resource but rather a relationship.

I combed through the relationships section of Ash and AshJsonApi but cant seem to find anything related to creating multiple related resources.

The best way to go about this is to use manage_relationship i.e

create :create do
  argument :relationship, {:array, :map}
  change manage_relationship(:relationship, type: :create)

Then you can provide that as an input.

I did try that with #1.

  data: {
   attributes: {...attributes},
   relationships: {
     authors: [{type: "author", name: "Eliel", email: "q232"}]

This got somewhere but seems to need an id attribute in the relationship. When I add that none of the other attributes in the relationship make it to the changeset attributes under authors.

The other way was to put the relationship in the attributes

  data: {
   attributes: {
    authors: [{name: "Eliel", email: "q232"}]

This did not work either, gave a invalid attribute error

It should be done in the attributes when using that strategy IIRC. It’s been a while since I looked at that particular code. What invalid attribute error are you getting?

Expected only defined properties, got key ["data", "attributes", "authors"].

This is my create action:

 create :create do
      primary? true

      argument :authors, {:array, :map}

      accept [..someparams]

      change manage_relationship(:authors, type: :create)

Okay, I can see it now, yeah. It should be in the relationships, but the issue is that we are currently requiring id, which doesn’t make sense in all contexts. I’ve just pushed something to main to make those optional. Additionally, extra attributes have to go in the "meta" key of the relationship, i.e {type: "type", "meta" => {foo: "bar"}}. This is required by the spec, IIRC.

1 Like

I think that would work! The json api spec for v1 is a little weird with this, I wonder if the upcoming v1.2 spec makes it easier to do this

1 Like

On a similar note, I have a situation where I have to create a Comment.

When creating a comment it should have the associated Post it belongs to. I know we can get the data on a related resource for eg. GET /post/:id/comments, but when I try to send a ‘POST’ request to the same url, I get a route not found error.

Question is, how do we post to a related resource? I tried just posting to the direct resource url, eg /comments, but then I have to manually attach the relationship, and create two different actions on the Comment resource, one for when creating the comment through a Post (I would like to be able to create a comment when creating a new Post), and another when creating a comment after a Post has been created.

Honestly not sure what the idiomatic way for JSONApi would be.
Should I have a PATCH on Post eg /post/:id/comment, route: "/:id/contributors" (this is on post json_api routes), and an action on the Post resource that delegates creation of the Comment through the managed relationship? Or should it be a POST on /post/:id/comments that goes directly to the Comment create action?

Example for reference:

  Post resource:

  json_api do
    type "post"

    update :add_comment do
      argument :comment, :map, allow_nil?: false

      accept []

      change manage_relationship(:comments, type: :create)

    routes do
      patch(:add_comment, route: "/:id/comments")

So, that part is actually still based on old behavior, and probably needs to be upgraded at some point. What it does is use the primary action and explicitly adds Changeset.manage_relationship (instead of it being an argument in an action).

So you can do this in routes:

post_to_relationship :comments

I do have that on the Post resource, but getting a no route found when hitting POST /post/:id/comments

Right, so this is for editing the relationship, its /post/:id/relationships/comments. However, that isn’t for creating new things, I just reread your initial post and now I see what you mean. This should likely be done as POST /comments specifying a post id to be the most REST-ish. We can add the option to ignore the base-route for some routes, that way on comment you could do: create :create, route: "/post/:post_id/comments", base_route?: false and have it pass the post_id through.

Thats not bad. Although, would I have to have 2 create actions? When creating a Post, I create a Comment alongside through the managed relationship, but If I also want to create a Comment for a Post, I need another create action that specifies an argument post, :map, allow_nil? false.


Comment resource:

create :create_direct do
  argument :post, :map, allow_nil?: false
  accept [...]
  change manage_relationship(:post, type: :append)

create :create_managed do
  primary? true
  accept [...]

You can simplify a bit if you do

belongs_to :post, Post do
  attribute_writable? true

then they can provide the post_id directly as an input. Then

create :create do
  accept [..., :post_id]
  primary? true

And then use that one action in both. Since post_id is not nullable, you will always be prevented from creating a comment with no post, and the manage_relationship will set post_id automatically.

1 Like