Beacon CMS doesn't run with Phoenxi 1.7 rc

Hey Guys,

As a precursor to my New Year resolutions, I thought I would wire up a blog using Phoenix 1.7 & Beacon CMS.

I ran across an issue related to LiveView version conflict. I have raised an issue over on their Git Repo:

  1. Does anyone have a running instance of Beacon CMS?
  2. Do people prefer Nimble Publisher?

Hey! I know you’ve already seen my PR for safe_code. An extra issue I ran into was running mix tailwind.install before the mix ecto.reset task when following the Beacon README.

Other than that, I’ve been able to get Beacon running with Phoenix 1.7. Any questions just shout!

1 Like

Yup, I saw it. Thanks for such a super fast fix!!

I hope it gets merged, I would like to check Beacon out and use it.

Can you also fix the Phoenix Live Storybook not working with Phoenix 1.7rc as well? :sweat_smile:

I was jus randomly changing paths here and there to make it work.

You can just patch it in your local version of safe_code to trial Beacon without it being merged. Head to /deps/safe_code/mix.exs and apply the change. Rerunning mix deps.get (plus the Tailwind install) should get you a running Beacon app.

I’ve not come across Storybook before and don’t have time today to dig into it. Are you only seeing those issues with 1.7? From what I know of the changes I think you might have the same issue with earlier versions too.

1 Like