Caching Dialyzer output with GitHub Actions

Hey everyone!

I’m curious why Dialyzer does a full analysis even when I cache the _build directory when using GitHub Actions. My deps directory is also cached and that works fine. It doesn’t try to pull deps if they’re cached.

My Dialyzer setup is pretty vanilla. I include dialyxir (1.0.0-rc) in my project and run mix dialyzer. No additional configuration in mix.exs.

Here’s the relevant section for my workflow config.

Thanks in advance to anyone that can help.

dialyzer:
  runs-on: ubuntu-latest

  strategy:
    matrix:
      elixir: [1.9-alpine]

    steps:
      - uses: actions/checkout@v1

      - uses: actions/cache@v1

        with:
          path: deps

          key: dependencies-${{ hashFiles('mix.lock') }}

      - uses: actions/cache@v1

        with:
          path: _build

          key: build-${{ hashFiles('mix.lock') }}

      - name: Pull elixir:${{ matrix.elixir }}

        run: docker pull elixir:${{ matrix.elixir }}

      - name: Run mix dialyzer

        run: |
          cmd='
            mix local.hex --force;
            mix local.rebar --force;
            mix deps.get;
            mix dialyzer;
          '

          docker run \
            --mount type=bind,src=`pwd`,target=/usr/src/malomo-bus \
            -w /usr/src/malomo-bus elixir:${{ matrix.elixir }} \
            /bin/ash -c "$cmd"
3 Likes

The PLTs are not where you expect them, please read the PLT section in the dialyxir manual. There you will also learn how to adjust the settings to suite your CI:

1 Like

Thanks for pointing that out. I’m going to assume :plt_core_path is the problem. On a fresh run I’m assuming the core PLT files don’t exist in $MIX_HOME which requires a rebuild. I’ll give that a go.

This was it. Setting :plt_cor_path to "_build/#{Mix.env()}" in mix.exs did the trick. CI builds are super quick now.

2 Likes

Side note, I think you should include the elixir and erlang version in your cache-keys, so that it will break the cache when you increment those versions.

Typically you would add a version (v1) to the key, but since GH Actions puts the versions in your matrix in scope you can use those.

6 Likes

Oops, just noticed I have a typo. It should be :plt_core_path instead of :plt_cor_path.

3 Likes

Not sure what changed, but I tried using the typo’d version of that option and the cache still worked, so I removed it.