Cannot install asdf erlang 24.1 on MacOS Big Sur

The command i used:

KERL_CONFIGURE_OPTIONS="--with-ssl=$(brew --prefix openssl)" asdf install erlang 24.1

error details:

asdf_24.1 is not a kerl-managed Erlang/OTP installation
The asdf_24.1 build has been deleted
Extracting source code
Building Erlang/OTP 24.1 (asdf_24.1), please wait...
Build failed.
 ERLC	../ebin/crypto_ec_curves.beam
 VSN	../ebin/crypto.app
 VSN	../ebin/crypto.appup
 MAKE	opt
make[4]: x86_64-apple-darwin20.6.0/Makefile: No such file or directory
make[4]: *** No rule to make target `x86_64-apple-darwin20.6.0/Makefile'.  Stop.
make[3]: *** [opt] Error 2
make[2]: *** [opt] Error 2
make[1]: *** [opt] Error 2
make: *** [libs] Error 2

I searched a lot of related questions, and tried some commands but still can’t install;
Has anyone encountered this situation? How is it solved?

Maybe the steps outlined in this issue on the asdf-erlang GitHub repository can help?

I try modify the kerl file, and also install wxwidgets@3.0, but still report the above error.

Don’t know if this will work for you but this is how I got erlang installed on a clean apple silicon machine running Big Sur:

  • install homebrew
  • brew install autoconf wxmac openssl
  • brew install asdf (then add asdf to .zshrc as per the output of the brew install command)

Then to install erlang:
export KERL_CONFIGURE_OPTIONS="--without-javac --with-ssl=$(brew --prefix openssl@1.1)"
asdf install erlang <version>

2 Likes

@riebeekn @Qqwy I’m truly grateful for your help!I installed it successfully.

I found the openssl version different.

KERL_CONFIGURE_OPTIONS="--with-ssl=$(brew --prefix openssl)" asdf install erlang 24.1

This installation command is used openssl@3 failed.

KERL_CONFIGURE_OPTIONS="--with-ssl=$(brew --prefix openssl@1.1)" asdf install erlang 24.1

this used openssl@1.1 success.

1 Like