Cannot ssh to Raspberry Pi Zero W with circuits_quickstart

Hi, I tried https://github.com/elixir-circuits/circuits_quickstart with Raspberry Pi 4B successfully. Then I tried Raspberry Pi Zero W with circuits_quickstart_rpi0.fw, using a USB cable connecting to my Mac.

In the document, it says

The Circuits Quickstart firmware configures Raspberry Pi Zero, Zero W, 3 Model A+, and any BeagleBone-compatible device in what’s called gadget mode. In gadget mode, the device uses a USB cable for power, serial console, and networking.

But I cannot ssh to it with ssh circuits@nerves.local. I confirm the Pi is booted as the green light keeps flashing. Did I miss anything? Thanks

Hi!
I guess you are connecting the wrong micro-USB port on rpi0 to the host PC. Gadget mode for nerves.local works with the inner USB port (the other one you are using).

Thank you, I switched to another port but still cannot ssh to it.

ssh just hangs without any output.

FYI, I connect Pi to Mac with two cables like MicroUSB <-> USB-A <-> USB-C.

I bought a Micro-USB to USB-C cable, expect it can work. Will update the post after I get the cable.

1 Like

I often hold Nerves hands-on workshop. In my experience, the USB cable that the participants brought was for charging only, so it didn’t communicate to the rpi0 board. And sometimes it was caused by the converter. (but FYI, I usually use the converter USB-A to -C for my Mac)
I hope the new cable you bought works fine!!

1 Like

Thank you, it should be the root cause. The new cable I bought is called OTG cable, which can charge and transfer data. I think it should work.

1 Like

@takasehideki Got the cable and it works, one cable to rule all, very cool! Thank you.

3 Likes