Compilation Error caused by Ecto after upgrading to OTP 26

Hello, i have an old running project build in elixir version 1.11.3 and erlang 22.3. Now after updating elixir to 1.15.4 and erlang/OTP 26, it is now throwing compilation error.

== Compilation error in file lib/ecto/query.ex ==
** (Kernel.TypespecError) lib/ecto/query.ex:430: type dynamic/0 is a built-in type and it cannot be redefined
    (elixir 1.15.4) lib/kernel/typespec.ex:961: Kernel.Typespec.compile_error/2
    (stdlib 5.0.2) lists.erl:1599: :lists.foldl_1/3
    (elixir 1.15.4) lib/kernel/typespec.ex:226: Kernel.Typespec.translate_typespecs_for_module/2

I already tried deleting _build folder then recompile again and also tried updating ecto but no success, any help :pray:

I want to be able to run this project again :pray:

Hi @winsalva you will likely need to either update your dependencies or use an older OTP version.

1 Like

Thank you sir. I just updated all of this project’s dependencies and it now compiled successfully :heart: