Connecting EC25 using VintageNetMobile

Hi there, I’m trying to use VintageNetMobile with a Quectel EC25 modem in a rpi4, but I haven’t been able to get it work, when I run VintageNet.get_by_prefix([]) I got (the part related with ppp0):

  {["interface", "ppp0", "config"],
   %{
     type: VintageNetMobile,
     vintage_net_mobile: %{
       modem: VintageNetMobile.Modem.QuectelEC25,
       service_providers: [%{apn: "imovil.virginmobile.cl"}]
     }
   }},
  {["interface", "ppp0", "connection"], :disconnected},
  {["interface", "ppp0", "state"], :retrying},
  {["interface", "ppp0", "type"], VintageNetMobile}

It is posible to send AT commands (I don’t know why that works, because AFAIK the /dev/ttyUSB3 is used by VintageNetMobile.Modem.QuectelEC25)

iex(19)> Elixircom.run("/dev/ttyUSB3", speed: 115200)
at
OK
ATI
Quectel
EC25
Revision: EC25AUFAR02A04M4G

OK

the last thing that I get with dmesg

[    6.798652] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    6.804770] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled
[   11.064161] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   13.058396] usb 1-1.3: new high-speed USB device number 3 using xhci_hcd
[   13.199423] usb 1-1.3: New USB device found, idVendor=2c7c, idProduct=0125, bcdDevice= 3.18
[   13.208005] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   13.216335] usb 1-1.3: Product: Android
[   13.221219] usb 1-1.3: Manufacturer: Android
[   13.305067] usbcore: registered new interface driver option
[   13.310936] usbserial: USB Serial support registered for GSM modem (1-port)
[   13.318297] option 1-1.3:1.0: GSM modem (1-port) converter detected
[   13.324980] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB0
[   13.332511] option 1-1.3:1.1: GSM modem (1-port) converter detected
[   13.339184] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB1
[   13.346472] option 1-1.3:1.2: GSM modem (1-port) converter detected
[   13.353126] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB2
[   13.360397] option 1-1.3:1.3: GSM modem (1-port) converter detected
[   13.367007] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB3

It’s important to note that I connect the modem with the rpi4 through USB, using an adapter. Any suggestion on how to debug the problem?. I tried connecting the modem in a Linux based computer and it worked (the ppp connection)

Could you check whether the wwan0 network interface is present? VintageNet.info and ifconfig can do this.

VintageNetMobile wants that the wwan0 interface is present before it even attempts to set up the PPP connection on /dev/ttyUSB3. If VintageNetMobile were a little smarter it could do better, but I believe this is the problem.

Since you have the modem’s serial ports working, I’m inferring that you’ve enabled the required kernel modules at https://github.com/nerves-networking/vintage_net_mobile/blob/main/lib/vintage_net_mobile/modem/quectel_EC25.ex#L60-L66. If you haven’t, then maybe that’s the issue (plus I’m surprised that the serial ports showed up)

As a final guess, could you run dmesg? There might be a hint in the kernel logs as to why wwan0 isn’t showing up or maybe something else is happening.

Thank you for your answer.

I had a couple of modules missing (CONFIG_USB_SERIAL_WWAN and CONFIG_USB_WDM).

By the way, the same configuration works with the simcom 7600

1 Like

That’s really good to know about the simcom modem. When you get a chance, could you post a PR or an issue (and I’ll make the change) to the VintageNetMobile project with the Linux kernel options and anything else relevant to someone else using a SIMCOM 7600 modem?

Thanks again for reporting back!

It worked straight away with the configuration of the EC25, there is an issue related with simcom modems, I commented there.

just let me know if there is anything else to test

1 Like

This is great news, thanks @nadsat and @fhunleth .

Could you please share how you’ve enabled the required kernel modules?

And a sample use of the EC25 modem?

I added these modules to a base Nerves system (in my case was rpi4)

CONFIG_PPP=m
CONFIG_PPP_BSDCOMP=m
CONFIG_PPP_DEFLATE=m
CONFIG_PPP_FILTER=y
CONFIG_PPP_MPPE=m
CONFIG_PPP_MULTILINK=y
CONFIG_PPP_ASYNC=m
CONFIG_PPP_SYNC_TTY=m
CONFIG_USB_NET_CDC_NCM=m
CONFIG_USB_NET_HUAWEI_CDC_NCM=m
CONFIG_USB_NET_QMI_WWAN=m
CONFIG_USB_SERIAL_OPTION=m
CONFIG_USB_SERIAL_WWAN=m
CONFIG_USB_WDM=m
CONFIG_USB_USBNET=m
CONFIG_USB_NET_DRIVERS=m

in the nerves_defconfig

BR2_PACKAGE_USB_MODESWITCH=y
BR2_PACKAGE_PPPD=y
BR2_PACKAGE_PPPD_FILTER=y
BR2_PACKAGE_BUSYBOX_CONFIG_FRAGMENT_FILES="${NERVES_DEFCONFIG_DIR}/busybox.fragment"

and the busybox.fragment

CONFIG_MKNOD=y
CONFIG_WC=y

finally the configuration in target.exs

{"ppp0",
  %{
    type: VintageNetMobile,
    vintage_net_mobile: %{
      modem: VintageNetMobile.Modem.QuectelEC25,
      service_providers: [
        %{apn: "apn.provider.com"}
      ]
    }
}}

That worked for both EC25 and sim7600

1 Like