Cowboy's idle_timeout not working when debugging phoenix request in vscode

I was debugging a request implementation in Phoenix with vscode. After hitting the a breakpoint and ~60 secs later, i got the following shutdown error:

Starting debugger in directory: /Users/xxx/work/messages
Running with MIX_ENV: dev MIX_TARGET: host
...
paused process #PID<0.4139.0> exited with reason shutdown

I googled and found that we need to set a idle_timeout to fix this issue as follows:

# config/dev.exs
config :web_interface, WebInterface.Endpoint,
  http: [port: port, protocol_options: [idle_timeout: 5_000_000_000]],

I set it. But it didn’t work. The above error still occurred after ~60 secs.

Development env:
Phoenix: 1.7.2
cowboy: 2.10.0
ElixirLS: 0.21.3

Did you restart the server after changing the option?

yes, i restarted the debugger and still saw this issue