Current_user not found error after running phx.gen.auth

I have encountered this error on two different code bases in the last few days. After running phx.gen.auth and following the instructions (e.g., mix deps.get and mix ecto.migrate) and running the server, I get the following error

key :current_user not found in: %{conn: %Plug.Conn{adapter: {Plug.Cowboy.Conn, :...}, assigns: %{flash: %{}, ...

Both code bases were fairly small and neither had any form of User or authentication. One code base I ran phx.gen.auth for regular controllers and the other was for LiveView. Both had the above error. Every tutorial and guide I have watched has shown this to “just work”.

The problem seems to lie with the following code snippet in root.html.heex

    <ul class="relative z-10 flex items-center gap-4 px-4 sm:px-6 lg:px-8 justify-end">
      <%= if @current_user do %>
        <li class="text-[0.8125rem] leading-6 text-zinc-900">
          <%= %>

Phoenix version: 1.7.2
Elixir version: 1.14.5
Erlang version: 25

One of the code bases I ran phx.gen.auth on was from the pragstudio LiveView course.

Do you have the :fetch_current_user plug in place, in your router pipeline somewhere? That’s the plug that puts the current_user in the right place, to be able to pick it up later. The plug is generated and implemented in your MyAppWeb.UserAuth module.

Your @current_user assign can be nil, if there is no logged in user. But you must have the plug in place to at least have the assign available. At least, if you wish to use the root template as modified by phx.gen.auth.

Does it work if you put it in the live.html.heex or app.html.heex layouts? I don’t believe that @current_user works in the root layout and I believe you generally want to keep dynamic stuff out of root. See here.

When I had both dead and liveviews, I used a component for displaying this stuff and called it in each layout.

That should work. It’s how phx.gen.auth adapts the root template.

Ah ok. From my memory it didn’t used to work so I always put stuff in the layouts. I’ve otherwise never had this problem myself so it’s odd!

Yes, that was the problem. The plug was missing from the router. Thank you @linusdm

Odd that phx.gen.auth didn’t inject that code into the router pipeline for me. As I said, it just seems to work for everyone else.

1 Like

Maybe you modified the browser pipeline in the router in a way the generator was confused? I’m not sure how that works exactly, but should be easy to find in the phoenix sources. I’d expect a warning when the generator cannot inject the plug (the generators also warn when a file it wants to generate already exists). Good luck with the app!